Increase in error rate for serving new, uncached images in SGP region
Incident Report for ImageKit.io
Postmortem

It was found out that some of the new instances that were added for image processing in Singapore region were not able to access the correct client configurations for some customers due to some recent infrastructure changes for added security and better performance.

Due to the this reason, the images being served from these instances were getting timed out and the ones on existing instances were taking longer than usual because of the increase in load.

We have fixed the issue related to new instances not being able to access client configurations and all instances in all regions, Singapore included, are now working fine and image delivery times are back to normal.

Posted about 1 month ago. Sep 18, 2019 - 00:23 IST

Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 17, 2019 - 23:57 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Sep 17, 2019 - 23:39 IST
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Sep 17, 2019 - 23:00 IST
This incident affected: Image GET.