Global DNS issue on Google DNS 8.8.8.8
Incident Report for ImageKit.io
Resolved
The issue has been resolved. The same can be confirmed from AWS status page as well. We will keep updating this issue in case of further developments
Posted over 1 year ago. Apr 24, 2018 - 21:31 IST
Monitoring
This is an update regarding DNS resolution problems that you might face while accessing different websites over the internet. This is not related to ImageKit's systems which are working fine.

Visitors might experience DNS resolution issues while opening ImageKit URLs (and even other websites). As confirmed from different sources on the internet, this is a global issue related to DNS resolution if you are using Google's DNS (8.8.8.8) for resolution. Your customers might not be experiencing it as ISPs generally do not use Google DNS as the preferred DNS. You can try accessing the image from a different network and the URLs would work fine.
Posted over 1 year ago. Apr 24, 2018 - 17:50 IST