Increased error rate on uncached requests
Incident Report for ImageKit.io
Postmortem

At 12:20 PM IST, we started facing major outages across all our processing regions and servers. All uncached requests (missed from CDN and our internal caches) were not getting served during the impacted duration. The issue was partially resolved at 12:40 PM IST and completely resolved at 12:45 IST.

The issue resulted from a configuration change on our servers that got picked up around 12:20 PM IST when the issue started happening. Once our team identified the error, the configuration change causing the outage was handled on our servers as a temporary measure, and the service was restored.

Soon after, our technology team started making changes to ensure that such configuration changes do not impact the server uptime in the future. Our team will soon deploy the change across our systems to prevent this issue from recurring in the future. Meanwhile, the systems are completely operational, and our team is constantly monitoring the same.

Posted Sep 04, 2021 - 15:43 IST

Resolved
This incident has been resolved.
Posted Sep 04, 2021 - 13:12 IST
Update
We are continuing to monitor for any further issues.
Posted Sep 04, 2021 - 12:58 IST
Monitoring
A fix has been deployed in all regions and service is being monitored.
Posted Sep 04, 2021 - 12:45 IST
Identified
We have identified the issue and a fix is being deployed.
Posted Sep 04, 2021 - 12:20 IST
This incident affected: Image Transformation - SGP Region, Image Transformation - MUM Region, Image Transformation - EU Region, Image Transformation - US East Region, Image Transformation - US West Region, and Image Transformation - AUS Region.