Increase in error rate for serving new, uncached images in US1 region
Incident Report for ImageKit.io
Postmortem

There was a server migration and upgrade that happened in the US East region at about 13:40 IST. Though this was a routine activity with no foreseeable downtime, during this transition, because of an incorrect configuration on a few servers, the new servers were not able to connect to other services necessary for delivery of content. Therefore, uncached content requests going to these servers started ending in an error.

ImageKit's team mitigated the issue by correcting the config on all the impacted servers.

We are making changes to our internal processes to avoid such issues from recurring in the future.

Posted Oct 11, 2021 - 19:44 IST

Resolved
This incident has been resolved.
Posted Oct 11, 2021 - 14:46 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 11, 2021 - 14:40 IST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 11, 2021 - 13:57 IST
This incident affected: Image Transformation - US East Region.