Error in serving requests in Mumbai region
Incident Report for ImageKit.io
Postmortem

Earlier today, we ran into issues with scaling our systems in the Mumbai region, primarily because of an edge case identified in AWS's instance allocation. This resulted in a high error rate for customers using the Mumbai processing region a couple of times.

After identifying the issue, which lasted for about 16 minutes around 11:50AM IST and 8 minutes around 09:45AM IST, our team made some changes to get around this limitation and restore functionality in this region.

The service is completely functional now with no degradation in response times either.

Our team is also working on a long-term fix so that the corner case encountered today does not impact services in the future. We remain committed to ensuring an uptime as close to 100% as possible.

Posted Mar 15, 2023 - 14:55 IST

Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 13:39 IST
Update
We are continuing to monitor for any further issues.
Posted Mar 15, 2023 - 12:00 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2023 - 11:52 IST
Investigating
We are currently investigating this issue.
Posted Mar 15, 2023 - 09:45 IST
This incident affected: Image Transformation - MUM Region.